re = /"tg:\/\/resolve\?domain=([\w\d_]+)"/m
str = '<a href="tg://resolve?domain=Moron21Centuriesbot" class="tl_main_download_btn">Ссылка</a>,
<a href="tg://resolve?domain=Moron22bot" class="tl_main_download_btn">Ссылка</a>,
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end