import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"tg:\\/\\/resolve\\?domain=([\\w\\d_]+)\"";
final String string = "<a href=\"tg://resolve?domain=Moron21Centuriesbot\" class=\"tl_main_download_btn\">Ссылка</a>,\n"
+ "<a href=\"tg://resolve?domain=Moron22bot\" class=\"tl_main_download_btn\">Ссылка</a>,\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}