$re = '/"tg:\/\/resolve\?domain=([\w\d_]+)"/m';
$str = '<a href="tg://resolve?domain=Moron21Centuriesbot" class="tl_main_download_btn">Ссылка</a>,
<a href="tg://resolve?domain=Moron22bot" class="tl_main_download_btn">Ссылка</a>,
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);