// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)"tg:\/\/resolve\?domain=([\w\d_]+)""#).unwrap();
let string = "<a href=\"tg://resolve?domain=Moron21Centuriesbot\" class=\"tl_main_download_btn\">Ссылка</a>,
<a href=\"tg://resolve?domain=Moron22bot\" class=\"tl_main_download_btn\">Ссылка</a>,
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}