package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)"tg:\/\/resolve\?domain=([\w\d_]+)"`)
var str = `<a href="tg://resolve?domain=Moron21Centuriesbot" class="tl_main_download_btn">Ссылка</a>,
<a href="tg://resolve?domain=Moron22bot" class="tl_main_download_btn">Ссылка</a>,
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}