# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?!\s*"name":.*).*\n?|^\s*//gm;t' <<< "{
\"country_codes\": [
\"GB\"
],
\"institution_id\": \"ins_118309\",
\"name\": \"Barclaycard (UK) - Online Banking: Personal\", // I want to extract this line only
\"oauth\": true,
\"products\": [
\"assets\",
\"auth\",
\"balance\",
\"transactions\",
\"identity\",
\"standing_orders\"
],
\"routing_numbers\": []
},
\"institution_id\": \"ins_118309\",
\"name\": \"Metro Bank - Commercial and Business Online Plus\",
\"oauth\": true,
\"products\": [
\"assets\",
\"auth\",
\"balance\",
\"transactions\",
\"identity\",
\"standing_orders\"
],
\"routing_numbers\": []
}"