re = /^(?!\s*"name":.*).*\n?|^\s*/m
str = '{
"country_codes": [
"GB"
],
"institution_id": "ins_118309",
"name": "Barclaycard (UK) - Online Banking: Personal", // I want to extract this line only
"oauth": true,
"products": [
"assets",
"auth",
"balance",
"transactions",
"identity",
"standing_orders"
],
"routing_numbers": []
},
"institution_id": "ins_118309",
"name": "Metro Bank - Commercial and Business Online Plus",
"oauth": true,
"products": [
"assets",
"auth",
"balance",
"transactions",
"identity",
"standing_orders"
],
"routing_numbers": []
}'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result