const regex = /^(?!\s*"name":.*).*\n?|^\s*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!\\s*"name":.*).*\\n?|^\\s*', 'gm')
const str = `{
"country_codes": [
"GB"
],
"institution_id": "ins_118309",
"name": "Barclaycard (UK) - Online Banking: Personal", // I want to extract this line only
"oauth": true,
"products": [
"assets",
"auth",
"balance",
"transactions",
"identity",
"standing_orders"
],
"routing_numbers": []
},
"institution_id": "ins_118309",
"name": "Metro Bank - Commercial and Business Online Plus",
"oauth": true,
"products": [
"assets",
"auth",
"balance",
"transactions",
"identity",
"standing_orders"
],
"routing_numbers": []
}`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);