using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!\s*""name"":.*).*\n?|^\s*";
string substitution = @"";
string input = @"{
""country_codes"": [
""GB""
],
""institution_id"": ""ins_118309"",
""name"": ""Barclaycard (UK) - Online Banking: Personal"", // I want to extract this line only
""oauth"": true,
""products"": [
""assets"",
""auth"",
""balance"",
""transactions"",
""identity"",
""standing_orders""
],
""routing_numbers"": []
},
""institution_id"": ""ins_118309"",
""name"": ""Metro Bank - Commercial and Business Online Plus"",
""oauth"": true,
""products"": [
""assets"",
""auth"",
""balance"",
""transactions"",
""identity"",
""standing_orders""
],
""routing_numbers"": []
}";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}