#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?= *)([0-9.]+) *(\w+) *(\w+) *(\w+) (\w+) (.*)\n"
Local $sString = " 0.000987 4 1547 Rx D 8 34 23 16 0 232 3 0 0" & @CRLF & _
" 0.006485 2 18FEF200x Rx d 8 00 00 FF FA FF FF FF FF Length = 571789 BitCount = 147 ID = 419361280x"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")