import re
regex = re.compile(r"(?= *)([0-9.]+) *(\w+) *(\w+) *(\w+) (\w+) (.*)\n", flags=re.MULTILINE)
test_str = (" 0.000987 4 1547 Rx D 8 34 23 16 0 232 3 0 0\n"
" 0.006485 2 18FEF200x Rx d 8 00 00 FF FA FF FF FF FF Length = 571789 BitCount = 147 ID = 419361280x")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")