using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?= *)([0-9.]+) *(\w+) *(\w+) *(\w+) (\w+) (.*)\n";
string input = @" 0.000987 4 1547 Rx D 8 34 23 16 0 232 3 0 0
0.006485 2 18FEF200x Rx d 8 00 00 FF FA FF FF FF FF Length = 571789 BitCount = 147 ID = 419361280x";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}