#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\babc(\d+)_def((?!\1)\d{1,2})\b"
Local $sString = "abc1_def23" & @CRLF & _
"abc10_def99" & @CRLF & _
"but does not match for:" & @CRLF & _
"" & @CRLF & _
"abc9_def9" & @CRLF & _
"abc9_def99" & @CRLF & _
"abc9_def123"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")