import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\babc(\\d+)_def((?!\\1)\\d{1,2})\\b";
final String string = "abc1_def23\n"
+ "abc10_def99\n"
+ "but does not match for:\n\n"
+ "abc9_def9\n"
+ "abc9_def99\n"
+ "abc9_def123";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}