const regex = /\babc(\d+)_def((?!\1)\d{1,2})\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\babc(\\d+)_def((?!\\1)\\d{1,2})\\b', 'g')
const str = `abc1_def23
abc10_def99
but does not match for:
abc9_def9
abc9_def99
abc9_def123`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}