re = /\babc(\d+)_def((?!\1)\d{1,2})\b/
str = 'abc1_def23
abc10_def99
but does not match for:
abc9_def9
abc9_def99
abc9_def123'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end