$re = '/\babc(\d+)_def((?!\1)\d{1,2})\b/';
$str = 'abc1_def23
abc10_def99
but does not match for:
abc9_def9
abc9_def99
abc9_def123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);