#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\d+\.\d+\.\d+\.\d+:\d+[\r\n]*)(?:\1){2,}"
Local $sString = "172.27.0.1:22" & @CRLF & _
"172.27.0.1:21" & @CRLF & _
"172.27.0.1:23" & @CRLF & _
"172.27.0.1:23" & @CRLF & _
"172.27.0.1:23" & @CRLF & _
"172.27.0.1:25" & @CRLF & _
"172.27.0.1:25" & @CRLF & _
"172.27.0.1:24" & @CRLF & _
""
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)