$re = '/(\d+\.\d+\.\d+\.\d+:\d+[\r\n]*)(?:\1){2,}/m';
$str = '172.27.0.1:22
172.27.0.1:21
172.27.0.1:23
172.27.0.1:23
172.27.0.1:23
172.27.0.1:25
172.27.0.1:25
172.27.0.1:24
';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;