import Foundation
let pattern = #"(\d+\.\d+\.\d+\.\d+:\d+[\r\n]*)(?:\1){2,}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
172.27.0.1:22
172.27.0.1:21
172.27.0.1:23
172.27.0.1:23
172.27.0.1:23
172.27.0.1:25
172.27.0.1:25
172.27.0.1:24
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)