# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\d+\.\d+\.\d+\.\d+:\d+[\r\n]*)(?:\1){2,}"
test_str = ("172.27.0.1:22\n"
"172.27.0.1:21\n"
"172.27.0.1:23\n"
"172.27.0.1:23\n"
"172.27.0.1:23\n"
"172.27.0.1:25\n"
"172.27.0.1:25\n"
"172.27.0.1:24\n")
subst = "$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.