using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d+\.\d+\.\d+\.\d+:\d+[\r\n]*)(?:\1){2,}";
string substitution = @"$1";
string input = @"172.27.0.1:22
172.27.0.1:21
172.27.0.1:23
172.27.0.1:23
172.27.0.1:23
172.27.0.1:25
172.27.0.1:25
172.27.0.1:24
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}