use strict;
my $str = '172.27.0.1:22
172.27.0.1:21
172.27.0.1:23
172.27.0.1:23
172.27.0.1:23
172.27.0.1:25
172.27.0.1:25
172.27.0.1:24
';
my $regex = qr/(\d+\.\d+\.\d+\.\d+:\d+[\r\n]*)(?:\1){2,}/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";