using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w*)<?>?\s*=(?=(?:[^""]|""[^""]*[""])*$)";
string substitution = @"";
string input = @"import java.io.File;
import java.io.IOException;
import java.util.ArrayList;
import java.util.List;
private final String COMMENTS = ""test"";
private final String VARIABLE_NAME_REGEX=""(\w*)<?>?\s*=(?=(?:[^""]|""[^""]*[""])*$)"";
String test=""test"";
String test222;
String includeThisAlso ;
List <String> arr;
List <String> list=null;
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}