use strict;
my $str = 'import java.io.File;
import java.io.IOException;
import java.util.ArrayList;
import java.util.List;
private final String COMMENTS = "test";
private final String VARIABLE_NAME_REGEX="(\\w*)<?>?\\s*=(?=(?:[^"]|"[^"]*["])*$)";
String test="test";
String test222;
String includeThisAlso ;
List <String> arr;
List <String> list=null;
';
my $regex = qr/(\w*)<?>?\s*=(?=(?:[^"]|"[^"]*["])*$)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";