re = /(\w*)<?>?\s*=(?=(?:[^"]|"[^"]*["])*$)/m
str = 'import java.io.File;
import java.io.IOException;
import java.util.ArrayList;
import java.util.List;
private final String COMMENTS = "test";
private final String VARIABLE_NAME_REGEX="(\\w*)<?>?\\s*=(?=(?:[^"]|"[^"]*["])*$)";
String test="test";
String test222;
String includeThisAlso ;
List <String> arr;
List <String> list=null;
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result