import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\w*)<?>?\\s*=(?=(?:[^\"]|\"[^\"]*[\"])*$)";
final String string = "import java.io.File;\n"
+ "import java.io.IOException;\n"
+ "import java.util.ArrayList;\n"
+ "import java.util.List;\n\n"
+ "private final String COMMENTS = \"test\";\n"
+ "private final String VARIABLE_NAME_REGEX=\"(\\w*)<?>?\\s*=(?=(?:[^\"]|\"[^\"]*[\"])*$)\";\n"
+ "String test=\"test\";\n"
+ "String test222;\n"
+ "String includeThisAlso ;\n"
+ "List <String> arr;\n"
+ "List <String> list=null;\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}