import Foundation
let pattern = #"(\w*)<?>?\s*=(?=(?:[^"]|"[^"]*["])*$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
import java.io.File;
import java.io.IOException;
import java.util.ArrayList;
import java.util.List;
private final String COMMENTS = "test";
private final String VARIABLE_NAME_REGEX="(\w*)<?>?\s*=(?=(?:[^"]|"[^"]*["])*$)";
String test="test";
String test222;
String includeThisAlso ;
List <String> arr;
List <String> list=null;
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)