#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([^.\r\n]+\.)*(bbc\.com|bbc\.co\.uk)$"
Local $sString = "bbc.co.uk" & @CRLF & _
"bbc.com" & @CRLF & _
"analytics.bbc.org" & @CRLF & _
"stats2.bbc.com" & @CRLF & _
"" & @CRLF & _
"dontmatchme-bbc.com" & @CRLF & _
"dontmatchme.also-bbc.com" & @CRLF & _
"v2.dontmatchme.also-bbc.com" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")