$re = '/^([^.\r\n]+\.)*(bbc\.com|bbc\.co\.uk)$/m';
$str = 'bbc.co.uk
bbc.com
analytics.bbc.org
stats2.bbc.com
dontmatchme-bbc.com
dontmatchme.also-bbc.com
v2.dontmatchme.also-bbc.com
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);