// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([^.\r\n]+\.)*(bbc\.com|bbc\.co\.uk)$").unwrap();
let string = "bbc.co.uk
bbc.com
analytics.bbc.org
stats2.bbc.com
dontmatchme-bbc.com
dontmatchme.also-bbc.com
v2.dontmatchme.also-bbc.com
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}