using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([^.\r\n]+\.)*(bbc\.com|bbc\.co\.uk)$";
string input = @"bbc.co.uk
bbc.com
analytics.bbc.org
stats2.bbc.com
dontmatchme-bbc.com
dontmatchme.also-bbc.com
v2.dontmatchme.also-bbc.com
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}