import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([^.\\r\\n]+\\.)*(bbc\\.com|bbc\\.co\\.uk)$";
final String string = "bbc.co.uk\n"
+ "bbc.com\n"
+ "analytics.bbc.org\n"
+ "stats2.bbc.com\n\n"
+ "dontmatchme-bbc.com\n"
+ "dontmatchme.also-bbc.com\n"
+ "v2.dontmatchme.also-bbc.com\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}