package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([^.\r\n]+\.)*(bbc\.com|bbc\.co\.uk)$`)
var str = `bbc.co.uk
bbc.com
analytics.bbc.org
stats2.bbc.com
dontmatchme-bbc.com
dontmatchme.also-bbc.com
v2.dontmatchme.also-bbc.com
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}