using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<![/\d])(?:0\d|[1][012])/(?:19|20)?\d{2}(?![/\d])";
string input = @"Should match, mm/yyyy: 03/1973
Should match, mm/yy: 08/17
Should not match, not a month: 42/1991
Should not match, not a likely year: 11/9191
Should not match, 3-digit year: 04/123
Should not match, contains a day: 06/08/2017";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}