const regex = new RegExp('(?<![/\\d])(?:0\\d|[1][012])/(?:19|20)?\\d{2}(?![/\\d])', 'g')
const str = `Should match, mm/yyyy: 03/1973
Should match, mm/yy: 08/17
Should not match, not a month: 42/1991
Should not match, not a likely year: 11/9191
Should not match, 3-digit year: 04/123
Should not match, contains a day: 06/08/2017`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}