import re
regex = re.compile(r"(?<![/\d])(?:0\d|[1][012])/(?:19|20)?\d{2}(?![/\d])")
test_str = ("Should match, mm/yyyy: 03/1973\n"
"Should match, mm/yy: 08/17\n"
"Should not match, not a month: 42/1991\n"
"Should not match, not a likely year: 11/9191\n"
"Should not match, 3-digit year: 04/123\n"
"Should not match, contains a day: 06/08/2017")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")