import Foundation
let pattern = #"(?<![/\d])(?:0\d|[1][012])/(?:19|20)?\d{2}(?![/\d])"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Should match, mm/yyyy: 03/1973
Should match, mm/yy: 08/17
Should not match, not a month: 42/1991
Should not match, not a likely year: 11/9191
Should not match, 3-digit year: 04/123
Should not match, contains a day: 06/08/2017
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)