re = /(?<![\/\d])(?:0\d|[1][012])\/(?:19|20)?\d{2}(?![\/\d])/
str = 'Should match, mm/yyyy: 03/1973
Should match, mm/yy: 08/17
Should not match, not a month: 42/1991
Should not match, not a likely year: 11/9191
Should not match, 3-digit year: 04/123
Should not match, contains a day: 06/08/2017'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end