use strict;
my $str = 'Should match, mm/yyyy: 03/1973
Should match, mm/yy: 08/17
Should not match, not a month: 42/1991
Should not match, not a likely year: 11/9191
Should not match, 3-digit year: 04/123
Should not match, contains a day: 06/08/2017';
my $regex = qr/(?<![/\d])(?:0\d|[1][012])/(?:19|20)?\d{2}(?![/\d])/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}