using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\S)#([0-9\p{L}]+)";
string substitution = @"<a href=""/hashtag/$1"">#$1</a>";
string input = @"Testing#one #two #three.test but also with chineese #печаль #грусть #fıstıklıbaklava #чайная #джаз";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}