$re = '/(?<!\S)#([0-9\p{L}]+)/i';
$str = 'Testing#one #two #three.test but also with chineese #печаль #грусть #fıstıklıbaklava #чайная #джаз';
$subst = "<a href=\"/hashtag/$1\">#$1</a>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;