import re
regex = re.compile(r"(?<!\S)#([0-9\p{L}]+)", flags=re.IGNORECASE)
test_str = "Testing#one #two #three.test but also with chineese #печаль #грусть #fıstıklıbaklava #чайная #джаз"
subst = "<a href=\"/hashtag/$1\">#$1</a>"
result = regex.sub(subst, test_str)
if result:
print(result)