#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\bdata_\d{4}_\d{2}_v\d+(?:\.\d+)*\.(?:ZIP|zip)\b"
Local $sString = "data_2021_03_v1.0.zip" & @CRLF & _
"data_2021_03_v1.0.ZIP" & @CRLF & _
"data_abc_efg_19-01-v2.0.zip" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"DATA_2021_03_v1.0.ZIP"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")