re = /\bdata_\d{4}_\d{2}_v\d+(?:\.\d+)*\.(?:ZIP|zip)\b/
str = 'data_2021_03_v1.0.zip
data_2021_03_v1.0.ZIP
data_abc_efg_19-01-v2.0.zip
DATA_2021_03_v1.0.ZIP'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end