const regex = /\bdata_\d{4}_\d{2}_v\d+(?:\.\d+)*\.(?:ZIP|zip)\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bdata_\\d{4}_\\d{2}_v\\d+(?:\\.\\d+)*\\.(?:ZIP|zip)\\b', 'g')
const str = `data_2021_03_v1.0.zip
data_2021_03_v1.0.ZIP
data_abc_efg_19-01-v2.0.zip
DATA_2021_03_v1.0.ZIP`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}