using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bdata_\d{4}_\d{2}_v\d+(?:\.\d+)*\.(?:ZIP|zip)\b";
string input = @"data_2021_03_v1.0.zip
data_2021_03_v1.0.ZIP
data_abc_efg_19-01-v2.0.zip
DATA_2021_03_v1.0.ZIP";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}