import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bdata_\\d{4}_\\d{2}_v\\d+(?:\\.\\d+)*\\.(?:ZIP|zip)\\b";
final String string = "data_2021_03_v1.0.zip\n"
+ "data_2021_03_v1.0.ZIP\n"
+ "data_abc_efg_19-01-v2.0.zip\n\n\n"
+ "DATA_2021_03_v1.0.ZIP";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}