package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\bdata_\d{4}_\d{2}_v\d+(?:\.\d+)*\.(?:ZIP|zip)\b`)
var str = `data_2021_03_v1.0.zip
data_2021_03_v1.0.ZIP
data_abc_efg_19-01-v2.0.zip
DATA_2021_03_v1.0.ZIP`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}