#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)catch *\((\w+)\) *{[^}]+(\1)(\.stack)[^}]+}"
Local $sString = "try {" & @CRLF & _
" print(new Function (astatement)())" & @CRLF & _
"} catch (e) { print(e.stack) }" & @CRLF & _
"" & @CRLF & _
"try {" & @CRLF & _
" print(new Function (bstatement)())" & @CRLF & _
"} catch (exception) { print(exception.stack) }" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")